Install Susy to use with Compass in Mac Mavericks

Submitted by admin on Sat, 07/05/2014 - 11:02

<a href="http://susy.oddbird.net/">Susy</a&gt; is a powerful css grid preprocessor. Recently, I could not use Omega to do Drupal Theming and I have to use this css framework. If you want to install in Mac Mavericks, follow these steps

1. Remove old version of homebrew if it is necessary using this <a href="https://gist.github.com/SteveBenner/11254428">link</a&gt;.
2. Install RVM and update your Ruby version following instructions described <a href ="http://railsapps.github.io/installrubyonrails-mac.html"&gt; here </a>
<code>
$ \curl -L https://get.rvm.io | bash -s stable --ruby
$ rvm get stable --autolibs=enable
$ rvm install ruby
$ rvm --default use ruby-2.1.2
gem update --system
</code>
3. Remove old versions of sass, susy and compass following steps described <a href="http://www.zell-weekeat.com/a-complete-tutorial-to-susy/">here </a>
<code>
sudo gem uninstall sass && sudo gem uninstall compass && sudo gem uninstall susy
</code>
<code>
sudo gem install sass --pre && sudo gem install compass --pre && sudo gem install susy --pre
</code>

Etiquetas